Welcome to the Builder Academy

Question Bugs ...Report and help Fix

More
19 Jan 2013 16:57 #1380 by zusuk
Hey Nerian:

I tested the 'stock' way its set up, i.e. the way you listed the code the first time.

It seems to work completely fine:

Zusuf, a male ogre with blue eyes and a button nose, is standing here.


I'd suggest maybe making sure that all your constants are set for all your races, besides that I'm not sure why you'd have an issue and my version doesn't

-Zusuk

Website
www.luminariMUD.com

Main Game Port
luminariMUD.com:4100

Please Log in or Create an account to join the conversation.

More
24 Mar 2013 20:24 #1702 by Spencer
Replied by Spencer on topic Bugs ...Report and help Fix
I am running D20mud (and love it)..I am new to coding nad need a little help. I have a crash bug in fight.c and after unning gdb I am getting this:

Program received signal SIGSEGV, Segmentation fault.
make_corpse (ch=0x1a745e0) at fight.c:897
897 IN_ROOM(corpse) = NOWHERE;


And the code here is:

IN_ROOM(corpse) = NOWHERE;
char *tmpdesc = NULL, *tmpstr = IS_NPC(ch) ? ch->short_descr : which_desc(ch);
snprintf(buf2, sizeof(buf2), "corpse %s", tmpstr);
corpse->name = strdup(buf2);

snprintf(buf2, sizeof(buf2), "The corpse of %s is lying here.", tmpstr);
corpse->description = strdup(buf2);

snprintf(buf2, sizeof(buf2), "the corpse of %s", tmpstr);
corpse->short_description = strdup(buf2);
free(tmpdesc);



any help? Thanks in advance. :)

Please Log in or Create an account to join the conversation.

More
25 Mar 2013 00:25 #1703 by Nerian
Replied by Nerian on topic Bugs ...Report and help Fix
I remember having that same bug and it being something to do with the mud and generating the corpse


unfortunately I don't remember the fix for it...zusuk maybe you can shed some light on it because i do remember consulting with you on this one ...since you were the one who found the bug in Lost Lands

Please Log in or Create an account to join the conversation.

More
25 Mar 2013 00:34 #1704 by Nerian

zusuk wrote: Hey Nerian:

I tested the 'stock' way its set up, i.e. the way you listed the code the first time.

It seems to work completely fine:

Zusuf, a male ogre with blue eyes and a button nose, is standing here.


I'd suggest maybe making sure that all your constants are set for all your races, besides that I'm not sure why you'd have an issue and my version doesn't

-Zusuk




and I know this has been a while back, but life got busy.... the problem was only with people who were not introduced so if I made test1 and test2 and they had never met each other it would not show properly.

Please Log in or Create an account to join the conversation.

More
25 Mar 2013 11:15 #1707 by zusuk
Hey Spencer, can you give us the GDB output?

I think I remember the problem being that Gicker changed the code to not make a new object, but rather load an object and assign it as a corpse.

Double check to make sure you have a 'corpse' object that matches the vnum he's using in the code if that's the case.

Nerian: How ya doing man?? We released LuminariMUD if you want a copy, help yourself :)

-Zusuk

Website
www.luminariMUD.com

Main Game Port
luminariMUD.com:4100
The following user(s) said Thank You: Spencer

Please Log in or Create an account to join the conversation.

More
25 Mar 2013 21:29 #1710 by Spencer
all fixed...thanks for the help! :)

Please Log in or Create an account to join the conversation.

Time to create page: 0.258 seconds