Compiling on Windows - Visual Studio 2019

  • LordSmoke451
  • Topic Author
  • Offline
  • New Member
  • New Member
More
3 weeks 3 days ago #9888 by LordSmoke451
Compiling on Windows - Visual Studio 2019 was created by LordSmoke451
It has been a very very long time since I last tried to work in a MUD, and I found my old code... lets just save Visual Studio 5 was still around.
So having dug through many notes and details I found the TBA Mud repositories and wanted to start building some stuff from a long time ago, I have tried to follow the instructions, however running into an issue when compiling.

I am compiling it as a Console Application, and have around 66 errors all related to the Protocol.c file.
identifier "!AC" is undefined (protocol.c line 376)
identifer "SE" is undefined (protocol.c line 387)
identifier "SB" is underfined (protocol.c line 486)
identifer "DO" is undefined. (protocol.c line 491)

These are just some examples, but every error relates back to this.
I am very very rusty, and struggling to figure out what I have done wrong, and very sure it is a user issue. I am using the TBAMUD2020 file, and have also tried several other version but continue to get the same problem.

Any advice or help greatly appreciated...

Please Log in or Create an account to join the conversation.

More
3 weeks 3 days ago #9889 by Parnassus
Replied by Parnassus on topic Compiling on Windows - Visual Studio 2019
I see from some of my earlier posts that I had a lot of trouble with protocol.c too. We talk about some of the problems in  this thread .  I then posted my VS  adventures in  this other thread .  I don't know if it's helpful anymore since some things have probably changed.  Oddly, the errors usually reported seem to be "undeclared identifier"  rather than "undefined".  That post goes through all the changes I made to make the mud run on VS but I found them more by poking at stuff than knowing what I was doing.  Because of this, I'm not very helpful because I don't know why those changes made the mud run.  Well, except the part about the mud crashing every time a self-destruct trigger ran.  Have you already read that thread?  If it's not helpful, I'm sorry but I can't tell you why. 

Please Log in or Create an account to join the conversation.

Time to create page: 0.083 seconds