VS and WIndows help

More
1 year 4 months ago #8450 by Hanyo
VS and WIndows help was created by Hanyo
So I'm following the Windows guide for using VS to run TBA and try to get that up and running. I make it to the point in the guide where you 'Build Solution' at which point it's throwing too many errors and stopping the compilation.

Error examples:

Severity Code Description Project File Line Suppression State
Error C2065 'IAC': undeclared identifier Test World C:\Users\X...\protocol.c 376
Error C2065 'IAC': undeclared identifier Test World C:\Users\X...\protocol.c 376

Amongst many others. They ALL seem to be throwing from Protocol.c so I have no idea WTF I am doing yet at all :) Just trying to get thing up and running at base. Any help?

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #8451 by Hanyo
Replied by Hanyo on topic VS and WIndows help
Just kind of a bump to the thread, in hopes of getting some potential guidance in the right direction ^_^

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #8453 by WhiskyTest
Replied by WhiskyTest on topic VS and WIndows help
What are you using to compile and build?
Cygwin / Visual Studio 2019 .. / Netbeans ?

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #8454 by WhiskyTest
Replied by WhiskyTest on topic VS and WIndows help
Sorry after re-reading your post I see you mentioned VS.
I downloaded VS 2019 to have a look, and I gotta say it's a bit of a nightmare getting it to build.

After you've gone through all 17 steps in the Readme.msvc8 (which don't reflect the new layout of VS 2019 but you can find the sections eventually) AND you've added the preprocessor definitions to eliminate the deprecation warnings, you then need to make a change to protocol.c

In protocol.c add these lines:

@line 15
#include <malloc.h>

@line 34
#include "telnet.h"

That got it to build for me.

Honestly I'd recommend installing Cygwin to build and compile and run the MUD. It will save you headaches down the road.
If you're set on Visual Studio... don't be. Use Netbeans :D

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #8455 by Hanyo
Replied by Hanyo on topic VS and WIndows help
I got it to compile and launch with cygwin so that toally worked thank you!

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #8456 by WhiskyTest
Replied by WhiskyTest on topic VS and WIndows help
Nice work!

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #8457 by Parnassus
Replied by Parnassus on topic VS and WIndows help
Sorry I didn't see this earlier but if you still wanted to try VS for some reason (or for anyone else that reads this that wants to try VS) you could try following my post here. It would be interesting to know if it works for other people.
The following user(s) said Thank You: WhiskyTest

Please Log in or Create an account to join the conversation.

Time to create page: 0.104 seconds